Emails sent through XML-RPC API not showing up in Email Broadcasts

Summary of what I’m trying to do with the xml-rpc API:
Pull in a list of contacts based on an assigned tag
Create an email template
Send the email template to the list of contacts

Every thing is working fine, I’m just wondering if there is way to get these emails that I’m sending through the API to show up in the Email Broadcasts reporting tab? They currently do not show up there but if I drill down to an individual user, I can see the emails there with unopened/opened status.

Thanks for your help,
Danny M.

@martinc, do you know if this is something that has a purpose or an oversight? Basically, api created emails not showing in some reports?

I pinged the API support team to see if it was a bug/oversight and if so what a workaround would look like. In the meantime, one could try using the Funnel Service https://developer.infusionsoft.com/docs/xml-rpc/#funnel and see if that batches emails on the report.

1 Like

I just want to clarify after I did some further testing… If I create the email template with the API but send it using the Email Broadcast interface, it shows up in the reports. However, if I create the email template with the API and also send it using API, it does not show up. Thanks again!!

Here is what I was able to find out

It’s more likely that the email batch report does’t pick up the sent entries by design, as it would mix up what was sent by a user and what was sent by an integration. However, the XML-RPC API is Legacy, and design documents/decisions regarding it don’t exist.

1 Like