Delete an Email Record - REST API - Not Working

It seems like the delete api function is not working…
I am able to use the “Sent Id” to retrieve the email just fine but, when I use the exact same id to delete the email I am given this lovely error:

 {
 "message": "emailSentId is invalid"
 }

Is anyone else having the same issue? Am I missing something here?

Could you give us the full content of the request you are making, and the app id that you are making it against?

@TomScott

Sure! Let me clarify what I am doing first!

I very rarely have to use the delete email function. So, instead of building out anything I have used the interactive REST docs to do the work for me. (I am a bit lazy! :smile: )

That said the full request is: https://api.infusionsoft.com/crm/rest/v1/emails/7131?access_token=XXXXXXXXXX

The application ID in question is: sp448.

I even tried it this morning and I get the same error:

But when I try and retrieve the email it works just fine:

image

Also, I have tried updating the email in question and I get this response:

However, I am a full admin.

Maybe I am missing something. So, I hope you can help!

– Dillan

Okay, looks like you’ve indeed got a bug there, our support rep has logged a ticket to get it addressed.

Thanks!