When I search on a custom field I get no hits

I have a custom field called Age that is a number field. I have many that are still set to 0. I want to find them all and tag them so an age calculation can be done on them. However, when I search for “age equals 0” I get nothing. If I search for “Age less than 1” … nothing. I can see the records and they have 0 in the age field. Why can I not search for them?

Hi Dan,

I think what is happening is the system is showing an empty value (often times called null value) as the 0 character. What this means is that it looks like the value is 0, but it is actually empty so when searching for < 1 , the criteria is not met.

To test this go to your record and replace the default 0 by typing it in on your keyboard and clicking save. Then re-run your search and I think it would work.

If that is the case, you could apply a tag if the value is empty for that field somewhere in your campaigns or set the field to ‘0’ early in the lead process.

You are correct Mark. That is exactly what is taking place. I loaded the contacts by API and loaded a “0”. When I type over the “0” it works. How do I compare a field with “empty” in the campaign. I have never seen that option. I have seen equal to, greater than, etc … but not empty or null.

I suppose I can put 0 in there if the age is not greater to or equal to 1?

There is a (free) Novak Solutions tool for tagging a contact when a field is empty. It’s part of the Campaign Tools package, the specific tool is simply called “Field is Blank”, you set it up as an HTTP Post in any campaign, and it tags the contacts as they go through if the field or set of fields that you specify is blank.

You can use a legacy action set or setup a ton of rules in decision diamond. It’s highlighted here:

Since you’re using the API, you can just send an HTTP POST with the contactId and then use a PHP script to check the field + run an action set if empty.

FYI- when searching, there’s a ‘Data Exists’ search option under Misc Criteria BUT it only works with standard fields, so wouldn’t really help in this case… :sleepy:

infusion-data-exists