What changes do we need to make to use SSO authentication rather than API key?

Hi,
We have developed a plugin to send form submissions to Infusionsoft. It currently uses BOTH the Infusionsoft® Client ID and Infusionsoft® Client Secret, as well as the SSO authentication:


Can you please point me to documentation on how the integration should be updated?
Thanks,
Josh

I wouldn’t completely abandon the OAuth inclusion…maybe hide it for now? The api key will be phased out in the future so it’s best to ensure preparedness up front rather than having to go back to modify later. Also note that anything using the api key method cannot be included in the Infusionsoft marketplace.

Thanks! We get this error with the current configuration.

<img src="https://monosnap.com/file/Dleuuer5j4QDSl5N8IIdduuxGEuKni.png">


Also, please note there is no phone number on the error screen.

What changes do you recommend?

I can’t really track what’s going on as there is no way for me to pause the images. I’ll share the vid I did on OAuth and the common mistakes involved in hopes it will help. I know it’s about 30 minutes but it goes over quite a bit in that time:

Hi @Josh_Fialkoff, based on that video and error message it looks like you don’t have any Infusionsoft applications assigned to your account.

Thanks for your help @Nicholas_Trecina. On what URL can I verify that?

@John_Borelli Here’s an MP4 version of the screencast. Please let me know if that helps.

If you go to https://accounts.infusionsoft.com it will show you the accounts that are linked to your Infusionsoft ID.

Here it is @Nicholas_Trecina. I’m happy to show you the full image privately.

We introduced a bug late last week that displays the wrong error message. The fix is being deployed tonight. The real issue is that the client_id is invalid (either not active or just plain wrong).

This should be fixed now.

Thanks for the update. However, the problem remains.
Here’s a video after I cleared by browser cache:

@Josh_Fialkoff, we fixed the error message. So what you are seeing that we do not recognize your client_id. What is your client_id that you are sending, the video is cropping the url. client_ids are public so it is safe to post in here. Just don’t post the client_secret.

@Josh_Fialkoff,

Have you created your mashery account and setup the app in there and verified that it is set to active?

Here is a video with the client ID:
https://monosnap.com/file/ASlttK0ffdVhrxHdfiCN7sUvblQf9Z

Please let me know what you recommend.

We do not have a Mashery account.

If I make one now, how do we connect it to this?

Thanks,

Josh

@Josh_Fialkoff,

My vid on this covers that and other details:

That client_id is not in our system. What is your mashery username or application name?

Here it is:
Application
WordPress Gravity Forms integration
client_id
2ahsfpmddaj78p8ybs6eyax2

Why is this client id and the one in the video different?

Get Outlook for iOS

1 Like

You’re right. When we fixed that, it works. Thanks for your help!