UTM tracking integrations

Hi there,

We’re trying to incorporate hidden parameters on Leadpages with our UTM codes, and then integrate into Infusionsoft - has anyone ever done this before? Do I just create new tags with the same utm: source name or is there another one?

Thanks!

Hi Rebecca,

This generally takes some custom scripting / code. Any fairly decent web developer should be able to do this.

hope it helps!

Hi Mark,

Thanks for the help! I’ve figured out how to add the ‘custom fields’ for the five UTM parameters in Infusionsoft, which then show up in leadpages for integration. I’m not entirely sure it’s firing as it shows up as each source being ticked off under the new test contact - any experience there?

Thanks again

If you use iTracker360, it’ll capture all that data and push it into Infusionsoft for you. All you need to do is add the itracker JS snippet to your LeadPages. I have a lot of people who use it with leadpages and leadboxes.

Disclaimer: I developed iTracker360 so reach out to me if you have any questions about it.
https://go.itracker360.com/

Thanks,
Casey
Email: casey@itracker360.com

Hi Rebecca,

There should be a setting for the hidden field to use a url parameter for the field value. Is that set? This would move the UTM parameters from the URL to the fields for for submission.

When you say each source is ticked off - is this a tag or something in the campaign?

Do you have a link to the page?

thx!

Thanks both! Mark here is the link:

https://oceanscapeyachts.lpages.co/book-giveaway-osy-video/

and here is a screenshot of how I have the parameters set and how i have it filled in .

Appreciate all the help!

It looks like the form is using the ‘placeholder’ for those values. This shouldn’t be the case given the settings you provided. It might sound silly, but is the page approved in leadpages?

If it is indeed approved, maybe try a test (temporarily) where the form is not a pop-up and see if the fields populate.

I tried this link in the example above. If working than source would be ‘testSource’.
https://oceanscapeyachts.lpages.co/book-giveaway-osy-video/?utm_source=testSource&utm_medium=testMedium&utm_campaign=testCampaign

Cheers Mark! We got there in the end - it was indeed the popup causing issues! Thanks again for your help :slight_smile: