Using an older SDK with PHP 7.1


(Matthew Burg) #1

Hey there - this question is a bit odd, but due to various reasons, we are just getting around to updating our server from PHP 5.4 to PHP 7.1.

With this change of course comes verifying that we won’t break anything during this update - which mostly seems to be a nonissue. However one point of possible concern is our infusionsoft SDK. I looked through the changelog, and we have been using the same SDK for many years now, which looks like the last change was in 2009.

This has functioned without any issues for all of this time, but this update to PHP is fairly considerable, and I am worried that it would break a lot of currently existing functionality. We are obviously looking to update to the newest SDK as well, however the newest php SDK isn’t compatible with our current version of PHP, so we’re looking to see if there are any known reasons for the old SDK to not function on the newer PHP (7.1), at which point (once it is updated) we can update to the newest SDK.

If there is somewhere within the SDK files I can get an exact version number or anything, I can definitely do so, but for now all I can say is that this is the last change: 2009-09-05


(John Borelli) #2

Hi @Matthew_Burg,

I’ve implemented api integrations with the current api on 5.3+ and have had no report of issues. Has anyone tested this for you? Are you going off documentation somewhere or is this something you have seen yourself? I’ve also ran both the sdk and the current api at the same time on 5.3 but not every server config will be the same and I don’t know all that would affect this so testing is really the only proof of anything.


(Matthew Burg) #3

The current (newest php sdk) says that it requires 5.5 or newer - see: https://developer.infusionsoft.com/resources/helper-libraries/

However you haven’t had any issues with that version on an older php version? If so, that’s perfect, we can start updating the SDK before we update our php to 7.1!


(John Borelli) #4

I would say in all likelyhood, as most develpers do, they provide compatibility notices based on what they’ve tested working. Which is different than testing previous versions to see if they fail. I would do a test just for certainty’s sake and of course, do backups, but you should be ok.


(Matthew Burg) #5

Fair enough - Ill give it a shot and see how it goes - thanks!


(Pav) #6

If you have problems, drop me a message as I have a enhanced Legacy iSDK that works on PHP v7.