URL link does not work properly

I have the following code within my email “https://gi362.infusionsoft.com/Contact/manageContact.jsp?view=edit&ID=~Contact.Id~#FormId_select”. However when I click on the link it links to my profile and not the Contacts profile.

Can you please explain how to stop this?

PS
When the link is displayed in the email the correct ContactID is shown.

If you try to use a link like that then to view contact information (even if it’s there’s) would require a user login to your app. That’s why you’re seeing what you’re seeing. In short, that won’t work.

Thanks

Do you what will work? I just want to link the the onwners Contact details.

Can you assist?

I’m not clear on what you envision by “link the owner’s contact details” but it sounds like the api might be necessary for this. Maybe more specifics?

I think what @Marcel_Labouchardier wants to do is send an email to a staff member perhaps that has a link that when clicked will go to the contact’s record. Is that correct, Marcel? If so, there are ways to do this w/o using API.

  1. One way is to use this link formation: ~Contact.FirstName~'s Profile:
    https://fk235.infusionsoft.com/Contact/manageContact.jsp?view=edit&ID=~Contact.Id~

Note: It will not be clickable - do NOT hyperlink it or it will link to the staff contact record.

  1. Another way that is more elegant is to add a merge field and some html in an HTML snippet in your email to make it clickable - here’s what I use - I tried adding the code itself and it converted it so here is a screencast of the code:

Hi Cheryl

Thanks for your assistance

Yes this exactly what I am trying to do. Can you advise how to view the screencast as I am having a problem viewing it? Please note I am using the link below, which is exactly like the one you suggested except without #FormId_select.

https://gi362.infusionsoft.com/Contact/manageContact.jsp?view=edit&ID=~Contact.Id~#FormId_select https://gi362.infusionsoft.com/Contact/manageContact.jsp?view=edit&ID=~Contact.Id~#FormId_select”.

This link works when entered directly into my browser. However when I click on it in an email it does not work.

Regards…Marcel

Marcel, if you click inside the box (click on the date), you’ll see an image of the html to go in an HTML snippet. Every time I tried to post it, it just created a hyperlink.

Hi Cheryl

Thanks Any comment on the link? Why it works in my browser.

Regards Marcel

I’m not sure, Marcel. I’ve never used that link formation before. I’m sorry :frowning:

Marcel, I’m using a merge field, not the URL that you are using. I’m using ~Contact.EditPage~ along with html code to make it into a text hyperlink. You must use it in an HTML snippet or it will pick up the details of the record of the person clicking on the link.

That’s about the extent of it :slight_smile: The html snippet is mandatory if someone other than the contact is clicking the link.

Hi Cheryl

Is there any other way you could you provide me with the HTML code so I can paste and modify in my email. I can’t see the code in the screen link

Marcel

I attached a text file with the code in it, Marcel. I hope that works :slight_smile: It’s just a sentence with the merge code in it. Put this in an html snippet in the email template.Contact Edit Page Script.txt (155 Bytes)

2 Likes

Thanks Cheryl

I will give it a go

Marcel

You’re very welcome :slight_smile: Let us know how it works for you, Marcel.