Updating from PHP 5 PHP 7

Hi team!

We are planning to update our PHP from 5 to 7 and we are currently using legacy api. Is legacy still compatible with PHP 7? What are your experience using legacy with the latest version of PHP?

Hi John,

From what you are saying I guess you maybe using an old version of Infusionsoft API SDK “iSDK”? Unless you developed your own code to handle the XML-RPC API functions?

The Legacy API will still run in PHP 7, but if you are using the iSDK you will get a bunch of PHP Notification Warnings.

Unfortunately the old iSDK is no longer officially supported. The newer iSDK will be more PHP v7 compatible, but it is not backwards compatible with the old iSDK due to it being redone from scratch again. If you want to go down that route, that would require changing your code. Here is the link to the new iSDK.

An alternative would be to use my version of the iSDK which was brought up-to-date to PHP v7.0, which you will find via the link below. It is a drop in replacement for the old iSDK.
The only snag is that if you run it with PHP v7.2 you will get PHP Notification warnings from the XML-RPC code. You can replace the XML-RPC code by downloading the latest version and tweaking the iSDK to load it, which I can provide.

Not sure if anyone else provides backwards iSDK support.

Apart from the iSDK, depending on how your code is written, you may have other issues to deal with when upgrading to PHP v7.

2 Likes