sendTemplate for existing invoice

First off, Infusionsoft is sending two invoices when we check: Email receipts/invoices upon successful payment and use the api to manually pay the invoice. If this wouldn’t happen, we wouldn’t need the next part…

We would like to use sendTemplate to send a payed invoice. However, there does not seem to be a way to set the invoice/order id, so all the order metadata is not populated (~Invoice.PurchaseRows~). Any ideas or is it even possible?

Thank you

We experienced an issue last week regarding duplicate invoices, which should be resolved now. If this is still occurring for you, we will need to open a ticket to resolve it as well.

We have a mechanism for sending emails in the XMLRPC API (“APIEmailService.sendEmail”) which could be used to construct an invoice email from other API data, but we do not currently have a method to send a variable invoice to a contact.

There are two places that there are settings to manage automatically sending receipts.

One is under ecommerce -> settings and selecting the orders item to the left:
image

The other is under ecommerce -> e-commerce setup and selecting receipts under the payment category:
image

Have you tried/check either or both of these?

Thank you for your reply. I received this from Infusionsoft…

“We experienced an issue last week regarding duplicate invoices, which should be resolved now”

FYI: We had the Email receipts/invoices radio to yes and the email receipt to false.

So your settings, as I understand it anyway, should only send one email receipt.

Tom,

I just tested this and I am still getting two invoices when using the API and no BCC from the template. When doing it thru the CRM we get 1 and the BCC.

Please advise,

Mark

@Mark_Bossard,

If you’re only seeing this through api calls then have you checked the api trigger for an action set that might be doing something…just a thought

I will check, but I doubt it. When the “Email receipts/invoices upon successful payment?” is “no”, we get no invoices. Also, the BCC didn’t work when using the API, but does when using the website.

I would suggest contacting the support team and having them verify your issue, and opening a ticket with them if required.

USA/Canada Toll Free
+ 1 866 800 0004 Ext. 2
Mon-Fri 6AM - 5PM Arizona Time

UK Freephone
+ 44 (0)808 258 0093
Mon-Fri 6AM - 5PM Arizona Time

AUS Free Call
+ 61 1800 730 419
Mon-Fri 6AM - 5PM Arizona Time

Mark, were you able to resolve the situation, or are two invoices still being automatically generated for each payment made via the API?

No we were not. However, we circumvented it by generating our own invoice.