Provely not working well with Infusionsoft web forms

We use a service called Provely on our registration pages. Provely generates a pop up bubble when someone enters their name/email address that provides social proof.

Up until approx. 1 month ago, this service worked perfectly with IS web forms. Since then, Provely is unable to capture the contact information. I have gone several rounds with Provely support trying to solve this.

They believe the Infusionsoft web form is loading on the page after Provely has already loaded. As a result, the contact information is not being pulled in.

They’ve asked me to inquire if there are any Infusionsoft outgoing web hooks available that can send the contact information to them. Does anyone know if this is possible or if there is another workaround?

Thanks in advance for your help.

To really answer this (given what you’ve described) we’d need to see the page (actually inspect the final generated code) to tell. Post a link?

Here is the link to the page: https://authoracademyelite.com/application

I turned the Provely display code off for the time being since it wasn’t working correctly and made it appear that no one has applied to the program in the last month.

Let me know if that is a problem.

I think it would make most sense to return it (temporarily) to the state that it was working in before the issue began. I can see the IS fields are correct but I don’t know the result of the other code without it being the same as it was.

OK. Then please use this page: https://karyoberbrunnerwebinars.com/webinar-replay/

It is having the exact same issue and there is far less traffic going there.

Thanks for your help.

Ok, so I only see IS fields there and if this is supposed to also address Provely it is quite possible that the way that IS uses jQuery that is could be getting lost in the transfer. They recently had some updates for performance issues and while I don’t know what the updates specifically involved, it is quite possible.

Have you reached out to support and asked them to escalate the issue to the developers?

I have reached out to Provely several times and they told me there is little they can do from their end.

I reached out to IS customer support and they told me to post my question here.

@John_Borelli, not sure if this makes a difference, but in the Application page the Infusionsoft Form is within an iframe element.

The Replay page has all the HTML code embedded, no iframe. Although the Replay is showing a “(index):648 Uncaught ReferenceError: Infusion is not defined” error, which is stopping the Calendar Icon from working.

We try to use the IS Javascript whenever possible. However, on certain pages the web form will not load correctly using Javascript. Then we move to using the html code.

As far as Provely goes, it has not made any difference in their ability to capture the contact information. Neither the Javascript or html code are working.

I noticed in the Replay page that the Provely is popping up at the bottom left with people activities. So that means it has loaded.

Although when entering the Name and Email Address I am seeing this being reported in Chrome.
“Cross-Origin Read Blocking (CORB) blocked cross-origin response https://app.provely.io/track/collect?campaignId=9301&seenCount=8&contacts=[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]%2C[object%20Object]&firstname=test&lastname=testtest&email=test%40example.com with MIME type application/json. See https://www.chromestatus.com/feature/5629709824032768 for more details.”

The Application page is not showing any of that. That is to do with it being in a iframe, which means Provely cannot see those fields directly.

There are Provely notifications showing. However, all of those are from a month or more in the past. That was when Provley was still working with the web form. None of the recent submissions are showing. That is where the problem is occurring.

I will share the cross origin blocking page with Provely.

OK. I think I figured out the solution.

The Javascript code from IS does not work with Provely. Unfortunately, when I replaced the code with custom html, it produced the web form on the page with all sorts of extra garbled text. It made the form look completely messed up and unworkable.

I replaced that form with one from a different campaign and now it works correctly. I will reach out to IS to see why the html code does not display on the page correctly.

Not sure about the iframe matter…I mean I heard it had a security issue and I know they recently did some updates for security and performance so it’s possible it was affected by something recent?