Problem With InfusionSoft Live Payment Processing


(Matt DeBole) #1

The Problem with Payment Processing:

The problem is with live payment processing on my WooCommerce Checkout page. (All previously testing in ‘test mode’ setting on WooComerce worked and synced perfectly with InfusionSoft.) When trying to purchase any actual product with an actual credit card, I get this error message at the top of the checkout page:

“Ref# None - FAILED_VALIDATION: The charge was null, payment failed validation; Credit Card Id: 0.0 Invoice Id: 91.0.”

WHAT DOES THIS MEAN!!! Here’s what I can observe… maybe it will help diagnose the problem:

On the InfusionSoft side, the correct Woocommerce Order (#3696) appears in the contact’s order history but as unpaid (owes the correct balance for that particular product).

On the Website side, the user can see this outstanding invoice reflected in their ‘Invoices’ page as well. However, the credit card information wasn’t ever recorded by InfusionSoft and therefore doesn’t appear in the ‘Manage Credit Card’ page.

On my “consumer” side, I do not get any sort of ‘fraud alert’ from my credit card or a message from my credit card company saying a payment attempt was declined.

So What’s Wrong? My hunch is that something could be off with a WooCommerce setting or InfusionSoft Merchant Account but I don’t know…

Does ANYONE have any idea what this error is or how to fix it?! I will be forever grateful because I’m really really lost on this one. Willing to provide necessary credentials for website, infusionsoft, etc to help solve it…


(Jon Smith) #2

Hey Matt,
It seems like from the error message the Credit Card isn’t being created correctly which means that no Id is being returned to be used by WooCommerce. As you suspect it could be either Infusionsoft or WooCommerce. There are a few problems that are going to make this difficult to troubleshoot. First it is dealing with Credit cards which shouldn’t be shared. The CVC also shouldn’t be shared on an open forum.

I would suggest first going to WooCommerce and let them know what you are seeing. Have them see if they see anything wrong on their side. If they can’t then get the request body and request headers that WooCommerce is sending to Infusionsoft. Also get the response body and response headers that are being returned from Infusionsoft. Since this is dealing with Credit cards don’t send the full credit card or the CVC. From experience this is rarely the issue plus this information would need to be transported in a more secure manner then through a ticket.

Speaking of tickets once you have this information head over here: https://developer.infusionsoft.com/support/tickets/create/
Make sure to add your application name in. Don’t worry about the developer application since it isn’t something that you have access to see. Hopefully this can be resolved quickly so you are able to start selling product.


(Matt DeBole) #3

Thank you so much Jon! My suspicion is that the plugin InfusedWoo has
something to do with it.

Any favorite plugins that reliably integrate WooCommerce with InfusionSoft
that I can switch over to? Thanks again!!


(John Borelli) #4

What payment gateway is being used? I would isolate that and test it separate from IS or WooCommerce.