Posting web form on social media

I have a webform/campaign that I want to post on social media to promote an event, how do I post the campaign web form?

Hi Heath,
On your campaign’s landing page, click on the “Code” tab.
There you’ll see a Landing Page URL and a Custom URL.
For social networks, use the Custom URL so you can give the page a marketing-friendly URL.
Please let me know if you have any other questions!
Thanks,
Josh
Google AdWords Campaign 🔊 2017-09-05 09-42-27

1 Like

Hi Josh

Sorry about the late reply, your help was very useful.

It’s been a very busy time for us at Aspirin Business with re-branding, new website about to be launched, conferences and business academies to arrange.

Your information really helped and we are looking to do more of this in the future, LinkedIn is our biggest social media platform.

Best regards, Heath

2 Likes

That’s great to hear! Please let me know if there’s anything else I can do for you.

@Josh_Fialkoff - I’m new to infusionsoft - I can’t seem to find how to get to the page you’re describing in order to copy the “custom url” for posting on social media… please advise? Is this only related to Google Adwords, or is this related to generally posting landing pages on social media?

I’ve copied the URL that was originally generated by Infusionsoft for my landing page. Even though I changed the name of the landing page, it’s still showing up on Facebook and other places I post as the ‘old’ name of the landing page. Can someone advise? Additionally, the primary photo that appears on the landing page isn’t showing up in the link preview of a Facebook post, but rather, it’s showing my company logo which isn’t helpful in generating interest in the post I’m trying to create. What do I do so that proper name shows up? And how to get the picture to show up properly in the link preview? AND YES, I’ve already hit “Publish” again after making the changes. AND YES, I have waited for a few days for the changes to kick-in, but nada. Help!

Additionally, I’ve put the URL into the Facebook Debugger but get this warning: Provided og:image URL, was not a valid URL. I don’t know what to do next. @Josh_Fialkoff

Hi @Ashley_Anjlien_Kumar!
Sorry to hear this isn’t working for you. Can you record a screencast (using something like https://screencast-o-matic.com/) and post a link here?
Thanks,
Josh

Yes. Here is the recording of me going through what I did to try to make the name of the landing page appear correctly. https://screencast-o-matic.com/watch/cFeihDDIBj

Hi Ashley,
This was for the old version of the landing page tool.
You’re using the new landing page tool, which has different options.
I believe you need to set up a custom domain in order to do this.
Here’s a screenshot:
Screenshot

Hi, it asked me to connect a sub-domain. I’m not a techie so don’t this stuff very well.
I followed the directions as best as I could but stuck when, after editing the DNS, one of the new DNS were not accepted. Can you guide me through this? I use a wix website. I wasn’t even sure what domain to use to connect to the landing page, and figured my website is ok? But not sure what impact this has on my website itself…

Hi Ashley,
This will require one-on-one help. Please email me at josh@forwardjump.com and let’s talk more.
Thanks,
Josh

Hi - I did manage to figure it out - there was something to do with debugging and scraping etc… :slight_smile:

There is also a wordpress plug, Infusionsoft Landing Pages for WordPress, in that lets you assign the IS url to your website. That’s what I’ve been doing because I get en error with setting up my domain via IS (I think the error is because we don’t use www in our website address.)