Landing Page User Interface Is Horrible what can I do?

Can anyone help me understand why I am having so much difficulty editing text on a Landing Page Template? I am using Chrome with all the cookies and history recently deleted on a very nice high quality clean PC.
This UI is so bad it is unusable? Why would Infusionsoft release this platform to us? See my screen cast below of how bad it is… I tried a different template before the one in this video and it to was horrible…

Sorry about that @Tony_States. I sent your video to the product team so that they are aware how frustrating that experience was for you. I appreciate you taking the time to record that.

I don’t have an answer as to what caused it. I played around with it myself this morning, trying to duplicate your experience and I couldn’t figure out how your text highlighting was losing focus, the cursor was jumping to the top, etc… The one thing I did notice is that the Undo/Redo buttons didn’t seem to undo or redo anything. If i learn anything from Support or Product as to what may have caused that issue, I’ll post it here.

@Tony_States,

As this isn’t something we’ve seen mentioned prior, I will suggest to you that it is likely an uncooperative browser plugin, which have been known to cause issues (especially Grammarly) OR just the need to clear internet cache which has cleared up a great many mis-behavior issues in IS in the past.

Thanks for the help Martin and John.
I am using Chrome with Windows 10 Pro fully updated.
I cleared my cache again and removed all but one (GOOGLE CHROME) extension and the problem is gone! Thank you for this suggestion!!!
If you guys agree we should leave this post here as it my very well help someone else with this problem.
If you prefer we can delete this post.
+++++
****One question I have about the landing page UI:
++++
The (Bullet Points) inside the landing page design area are black??? Why is that?
I want them the same color as my text… and when I make my text nice and big the bullet points stay super small and look really weird…
Bullet%20points%20inside%20landing%20page%20are%20black%20why%20is%20that%20SS-1%2010-10-19

According the PM of the landing page builder, “I’m watching the video now. The text box jumping was a bug that has since been deployed. As for the bullet colors and fonts, I have a story to have this feature resolved.”

So it sounds like Product was aware of the issues you were/are experiencing and are still working to resolve them all. I’ll let them know about the bullet size being off too make sure that gets fixed too -I assume that’s part of the overall bullet issue.

Great! Thanks again Martin!!