Java script iframe display issue

I’m using javascript for web capture forms, and having an odd display issue.

When I view the forms from my PC at home, the form displays fine in Firefox, but shows up truncated in Google Chrome and IE.

Viewed from my PC at work, the form displays fine in Chrome, but shows truncated in Firefox and IE.

Here is an example of what I’m talking about - first showing from Google Chrome and then Firefox: https://www.screencast.com/t/a1yDuesX

I’ve tried:

Clearing cache / cookies
Updating Java
trying from privacy mode / incognito window
Trying via VPN

And in all instances, same results.

I chatted with several different infusionsoft support folks, and all said it shows fine on their end on multiple browsers.

I then had some other people check, and they too are seeing what I see - different results on different browsers, but for each one, different browsers are displaying correctly vs. truncated.

Does anyone have any idea of what to try next? We dont want to use HTML or hosted forms as we need the ability to manipulate the forms in Infusionsoft without having to go back and then update the website (we have dozens of forms, and hundreds to add, as each form is customized to its landing page)

Website is built on Wordpress

Here’s an example, check it out in a few different browsers: https://www.merchantsolutionsllc.com/apply-now/

Any ideas?

1 Like

Hi Andrew,

I am having the exact same issue. I was not having this issue before, but suddenly today or within the last week our forms are being truncated. This varies in the browsers - Firefox, Chrome and Edge are not working on my PC, but shows correctly on Safari. I contacted Infusionsoft, but it is showing up correctly in for them. They stated that it is our website, but I know of no changes to our website or the browsers recently. Did you ever receive any solution?

I’ve just posted the same issue before I saw your post. The same thing happened yesterday for me. Have you found a fix yet?

Yes, we were able to get it resolved. How I’m not quite certain. I just reached out to my designer to ask specifically what they changed. I’ll follow up once I hear back.

Thanks Andrew - would be really appreciated.

I have the same issue and the support staff said to clear browser history and the form still shows cut off.

Thank you Andrew. I am experiencing the same problem. Let me know if you were able to track down what needed to be changed. I am also curious if you are using the full java snippet or if you just copied the html plain code and pasted. Thanks