Import field not available for importing

importing
(Mike Johnson) #1

There is a standard email field called “Email address 2”. It is needed to send an email to contacts with more than one email address.When I try to import data, this field does not show up on the drop-down when matching the fields. See screenshot. How can I get this field to accept data?

(Mike Johnson) #2

It is turned on.

(Martin Cash) #4

This will be fixed in the coming weeks; however, this will not solve your problem (assuming I understand you correctly). You can’t send an email to both addresses on the same contact record at the same time in a single broadcast/campaign…you would need to create a separate contact record so Keap can treat it as a separate entity.

(Mike Johnson) #5

This doesn’t make sense to have more than one record for each contact. What I wanted to do was send an email to email 1, then send it again to email address 2. Not at the same time, but in 2 runs. are you telling me that email address 2 field will not be available for weeks? I guess I’ll have to go back to Mailchimp and re-create the email. Sad thing is that tracking those emails in Keap won’t be possible.

(Martin Cash) #6

Sorry, Mike. I misunderstood what you were trying to accomplish. Yes, you can just create a new custom email field, import the secondary email into that new custom field and when setting up your template, just choose that custom field in the “To:” drop-down.

The only thing you can’t do currently is import directly into the default “Email Address 2” field at this time - that field will be opened up to the importing wizard in the coming weeks.

(Mike Johnson) #7

When you send a broadcast, there is no option to use a custom email field for sending emails. All you can use are the fields in the drop down box, which includes email address 2 so you must use that one. i have a custom field “Email 2” and I can’t use it to send emails. Maybe you should put this on your list as well, the ability to send to a custom email field would solve all of this for me.

(Martin Cash) #8

That should be working Mike -it works on my end. If it isn’t, it’s a bug. Did you make sure you set the field type to “Email” when you created the custom field?