HTML Code Builder stripping out HTML Code


(Kirsty Marks) #1

Hi there!

I am trying to use your HTML code builder option in the legacy email builder (drag and drop) and it appears to be stripping out my code both in preview and during sending.

This is valid HTML and i was advised by your chat team to paste into the HTML builder, preview (which reformats the code inline). However this still strips the code before sending and during the preview status.

Please can someone assist, as im trying to build some simple headers for my team to use in emails who are not very “tech” minded.

  1. Do I need to use full HTML (Head, Body etc)
    2.Why cannot conditionals be used for the likes of Outlook (which does need them)

I have placed a screenshot of my code and attached the screenshot of what it looks like in the email template builder.

Thanks
Kirsty




(Chicago Analytics) #2

Huge issue is all conditional outlook specific code gets stripped out, since I cant use the bulletproof background image which is what works for outlook as they dont support background-image or the background td inline its a huge problem


(Kirsty Marks) #3

Hi Chicago,

Thanks for the reply. The thing is this isnt even a background image!! This is just an image inserted into the table.

The fact is their inbuilt code builder has stated my HTML is invalid, which is nuts. Its not invalid in the slightest (Its been tested with Litmus).

I find it bizarre it chooses to strip out conditionals also! The fact is that we should be able to use these. My reason would be that as a dev, i know what these are and what these do, so we should be able to use them with a warning that our emails will not render should they be wrong. However it ignores this fact and strips them out.

A standard Joe Bloggs wouldnt use these within their templates, so why strip them out for people who actually know what they are, and what they are being used for.

We have since swapped to BeeFree (for non tech savvy people) to render our emails to use within Infusions HTML Builder, as clearly the code builder in the drag and drop template is not working in the slightest and causing huge issues in terms of our email builds.


(Tameca Robertson) #4

I have found that you can use conditional if statements in the broadcast email builder under the following conditions:

  1. Select Create HTML Email
  2. Add the entire HTML document you’ll be using for your email
  3. Without saving or exiting the builder, send a test and confirm after the test that the condition if statements (such as those for older versions of Outlook) are still in the email.
  4. If you have to exit the email, make sure you add back in the conditional statement before doing your final send.
    Apparently, InfusionSoft will strip out the conditional statement if you save the email before sending, but not if you add the conditional tags right before the send.

For example, our team sent an HTML email with the following conditional statement to style for older versions of Outlook:

After saving the following code was saved to the draft:

<o:OfficeDocumentSettings>
<o:AllowPNG/>
<o:PixelsPerInch>96</o:PixelsPerInch>
</o:OfficeDocumentSettings>

The conditional if tag had been dropped, and a 96 was showing up at the top of the email body.

I was able to add the full set of lines back just prior to the send and confirm that the resulting HTML email did not contain a 96 in the body, and the HTML page source for the delivered email contained the conditional statements.

This only works when you create an HTML email. The HTML snippet tool inside of the email builder is much less forgiving, and even this hack works only if you do it just right! :sunglasses: