How to disable the protected by recaptcha box in webforms

when i use the snippet a protected by captcha clickable badge shows on my form. It is impedeing my elements, how do I remove the protected by recaptcha box?
image

1 Like

The only way I know to turn it off is by checking this box on the settings tab of the form - but I’m not sure that this feature is available in all apps. I believe at some point they stopped allowing newer apps to manage this setting.

I do not wish to disable the protection, just remove the obtrusive icon from my form.

Greg, can this be elevated as a potential bug ?

Unfortunately, it is just how Google decided to implement the feature. There is some chatter about it on stackoverflow. The second answer provides a solution to set the class to invisible; however, it comes with a warning that it may break functionaltiy :frowning:

This kinda worked in JSfiddle…just adding the following CSS. I haven’t tested in a real world environment yet.

.grecaptcha-badge {
    display: none;
}

image

1 Like

Google has an option to turn off the recaptcha tag. Might be a helpful update to add this as an option.

https://developers.google.com/recaptcha/docs/invisible

Ive personally had to turn it off for all client forms because they don’t want it to show.

1 Like

@mjfleming @Greg_Jenkins Our management is having issues with it on our site. I got this email from our Practice Manager a couple hours ago:

“I have tried many times to sign up for our services and consistently get kicked out of registration because of the captcha - I also started watching other people do it and when they can’t get through the first time, they ignore the request and move on. I have to believe I am not the only person who is distracted and gets frustrated after completing my info and moves on.”

What happens when you disable Spambot Detection by not using Google reCAPTCHA? I bet we’re gonna open ourselves up for some serious spambots!

I would love to go back to the older Captcha functionality.

Sorry @Daniel_Johnson_Jr, I’m not sure how to help on this one!

@Greg_Jenkins After some research and talking with other experts, it seems that the recaptcha is triggered when she attempts to fill out the form quickly from her desktop. Most people who visit our site do so from a mobile device and will not be able to fill out the form as quickly.

Sadly, the older captcha has issues with firefox. Some users can plug in proper codes all day long and get nothing but invalid code errors. I have long-standing forms that still contain the old captcha and have updated them with the new captcha for the benefit of FF users.

Thank you for this tip, @martinc and for the stackoverflow link! We’ve implemented this workaround on our website and will see how things go.

1 Like