E-Commerce -> Actions -> Purchase Actions (Products) NOT WORKING?

troubleshooting
purchase-actions
(Morty Miles) #1

I am new to Infusionsoft. I am trying to get email notifications sent to the correct people after a specific product is purchased from the Infusionsoft Shopping Cart. Specifically, I am trying to get Product1 purchase orders sent to a specified email address. Later I will setup another action so that Product2 purchase orders go to a different email address.

I have a website on company.com which contains purchase product links to the products I have listed on my Infusionsoft account.

Here is what I tried:

E-Commerce Setup -> Actions -> Purchase Actions

In the Default Settings section, you see Actions for: “On Login (Multi-Step Cart)”, “Contact Creation Action”, “Successful Purchase Action”, “Failed Purchase Action”, and “Error Purchase Actions”. I did not setup any of these types of actions.

Instead, in the Products section, I type the first few letters of my product name, and then select it from its auto-fill entry. I then click “Actions” button next to it.

-I click the “Add New Action” drop-down, and select “Send an Email, Fax, etc.”
-In “What do you want to send?” I select “Email”.
-I click the “Add” button next to the “Edit” button so that I can create a new email template.
-I give the template a title like “Send Order Details to orderadmin@mycompany.com”. In the “From” field, I change it to one of the admin email accounts listed. I change the “To” field to "orderadmin@company.com".
-I set the subject to: “New Order for ~Contact.Email~”
-I set Send As to “Plain Text (no graphics)”
-In the Plain Text Editor, I have a template like this:

Name: ~Contact.FirstName~ ~Contact.LastName~
Email: ~Contact.Email~

Invoice ID: ~Invoice.Id~
Invoice Total: ~Invoice.InvoiceTotal~
Promo Code: ~OneTimeOrder.PromoCode~
Total Paid: ~Invoice.TotalPaid~
Order Type: ~OneTimeOrder.OrderType~
Order Date: ~OneTimeOrder.DueDate~

-I use the “Test this Email” and send a test message to a Contact account created with address of someuser@company.com
-I do successfully recieve the test email message when I check their mailbox account
-In “Ready to Send?” I set this value to YES.
-I click save.

-When I purchase this product, I do not see the “New Order for ~Contact.Email~” email-message in orderadmin’s mailbox.
-I tried changing the “To” email address to someuser@company.com (same address used in Test this Email), and I do another purchase order of the product. But I do not see the email send to the new email address either.

Can anyone tell me what I might be doing wrong?

(Jeff Arnold) #2

Morty:

The area you are working in (purchase actions, etc.) is kind of like the ‘legacy’ system inside Infusionsoft by Keap. In order to keep everything easy to see and organize, I’d recommend using the Campaign Builder to drive the activity you are trying to drive.

Set up a campaign with a Purchase Action as the Goal, then inside the sequence set up the email that you want sent out. Choose “Product A” in the Product Purchased goal and then set up the ‘to’ address in the outbound email in the sequence.

Here it would just be set up like this:

Try setting it up that way and see if it works.

Jeff

(Morty Miles) #3

Thank you for the suggestion Jeff. I am new to using the Campaign Builder. Here is what I tried:

  1. Clicked the Create Campaign button, and named my Campaign.

  2. Dragged a “Product purchased” Goal object onto workspace area. Double clicked the “Product purchased” object, and chose the “Specific Product Purchase”, and chose my specific product in the drop-down box.

  3. Dragged a “Sequence” object onto the workspace area. I double clicked the Sequence object which has a new workflow/workspace and a “Start” object already in it. I dragged a new “Email” Communications object onto this workspace. I double clicked the Email object and used the editor to create an Email message template. I set to “To” field in the template to orderadmins@mycompany.com.

  4. Still on the email Template screen, I used the “Test” button near top-right of screen and verified the email-message was sent to orderadmins@mycompany.com. I then set the template to “Ready”.

  5. I backed out of the Email-template workspace screen back to the “Sequence” workspace. I clicked the green arrow on the “Start” object to connect it to my “Email” object. I also set the sequence to “Ready”.

  6. I then backed out to the main top level workspace screen. I clicked the Green arrow on the “Product Purchased” object and connected it to my “Sequence” object. I then clicked the “Publish” button which first verified my Campaign, then offered me to push Publich button a second time to actually publish it. I did this.

  7. I then made a purchase for that specified product and waited to see if an email would get sent to orderadmins@mycompany.com. I did not recieve my email-template message in the mailbox of orderadmins@mycompany.com.

Here is more information I do not understand:

When I view the report on this Campaign, I see there is now 1 contact. The “Sequence” object does show a “1” next to it. But when I double click the Sequence object, the Email template object still has a 0.

I do not know why:

  1. Email (template) was not sent to orderadmins@mycompany.com after product purchased

  2. When viewing campaign report, it shows my new contact and a 1 next to my sequence, but my Mail object was never “activated”?

Any ideas?

Campaign Setup (Screenshots):

https://paste.pics/53dedf0d2b730bbcd5b4e98da04c58b7

https://paste.pics/081659fee20d8b2999d0d6f1731216c4

https://paste.pics/94cf54add8906931b51f5309c2728576 (reporting after making purchase)

https://paste.pics/e74be77d94a3a2361dd71328826a3a8a (reporting sequence after purchase)

(Jeff Arnold) #4

Morty:

There is nothing in your description of what you did or the images that you sent that would reflect why something would not be working. If you want to email me directly (Jeff@4SpotMarketing.com) maybe you could get me access to your system and I could take a deeper look into it for you. As Certified Partner, we have the ability to get access without using any of your user licenses.

Jeff